Forums

Potential Buff bar Fix

Quick find code: 16-17-86-66128634

of 2
ModáPoerkie

ModáPoerkie

Jagex Moderator Forum Profile Posts by user
hey all,

I've created a thread here to provide feedback from playing on the test worlds with the potential buff bar Fix on it.

You can read the short newspost here.
Community Manager! @JagexPoerkie

07-Nov-2019 10:35:01

Dayan
Jun Member 2012

Dayan

Posts: 235Silver Posts by user Forum Profile RuneMetrics Profile
Very cool to be able to test before the fix goes into the live game :)

It definitely looks like an improvement thus far. One thing I have noticed is that the reaper necklace buff icon isn't clearing.

Steps to reproduce:
-Equip reaper necklace
-Attack something to build stacks on buff bar
-Unequip the reaper necklace (or switch to a different amulet)

Edit:
Also noticed that the weapon poison buff icon doesn't disappear after death. Steps:
-Apply (drink) some weapon poison
-Die and be sent to Death's office
-Wait for the timer to run out - the icon remains on the buff bar

07-Nov-2019 11:35:33 - Last edited on 07-Nov-2019 12:19:04 by Dayan

GlicEsther
Feb Member 2023

GlicEsther

Posts: 970Gold Posts by user Forum Profile RuneMetrics Profile
I really don't know what's changed but I know that there's a divination potion running out because its on the most left, followed by combat buffs/debuffs. Also can't see how to align-right so I can put it on like the right side of the screen too..

But the icons don't stay after running out so long maybe. Were 'smart' tech speed stuff targets achieved but not the UX targets?
My ideas dump thread

07-Nov-2019 13:12:38

Tagakhlo
Sep Member 2014

Tagakhlo

Posts: 1,119Mithril Posts by user Forum Profile RuneMetrics Profile
I noticed in recent weeks that my Avatar Habitat boost icon was not visible for a short while, and that the positioning of buff bar icons was odd. And today when I logged in, I noticed I had an icon for a boost to Constitution, even though my hit points weren't boosted.

I logged in to the test world.

The Constitution boost icon was visible. I couldn't test the Avatar Habitat, since clan citadels are different worlds. So I slew some goblins, and made a bonfire with their bones.

Everything worked normally; but while the Constitution icon blinked off when the warmth of the bonfire wore off, it then reappeared. So it may be that while the fix avoids creating corruption to a user's data, it can't cope if the corruption was created before the fix.

07-Nov-2019 13:34:02

ModáPi

ModáPi

Jagex Moderator Forum Profile Posts by user
Dayan said:
Very cool to be able to test before the fix goes into the live game :)

It definitely looks like an improvement thus far. One thing I have noticed is that the reaper necklace buff icon isn't clearing.

Steps to reproduce:
-Equip reaper necklace
-Attack something to build stacks on buff bar
-Unequip the reaper necklace (or switch to a different amulet)

Edit:
Also noticed that the weapon poison buff icon doesn't disappear after death. Steps:
-Apply (drink) some weapon poison
-Die and be sent to Death's office
-Wait for the timer to run out - the icon remains on the buff bar


Hey, these look like live issues rather than beta specific issues, we'll get some live bugs written up for them so they can be fixed though.
Senior Gameplay Programmer
Combat Council Member
Check me out on twitter @JagexPi

07-Nov-2019 15:54:22

Dayan
Jun Member 2012

Dayan

Posts: 235Silver Posts by user Forum Profile RuneMetrics Profile
ModáPi said:

Hey, these look like live issues rather than beta specific issues, we'll get some live bugs written up for them so they can be fixed though.

Sounds good, thanks :) Haven't noticed any issues with it failing to update otherwise, so the fix is looking promising so far.

07-Nov-2019 16:36:32

CharityToken
Jan Member 2023

CharityToken

Posts: 64Iron Posts by user Forum Profile RuneMetrics Profile
Just finished testing out on a ed2 run up to Verak (i can use many buffs there to test). buffs seem fine and didn't disappear (typically they mess up around 5 minutes after re-logging for me on main client). not sure if its an issue with the test server, but I did have a noticeable lag the entire time I was on the server despite being forced into minimal graphics.

08-Nov-2019 01:52:05

Quick find code: 16-17-86-66128634Back to Top