Forums

Community: Linux Support 2.0Thread is sticky

Quick find code: 409-410-916-65990459

of 64
Weedmic
Jan Member 2009

Weedmic

Posts: 125Iron Posts by user Forum Profile RuneMetrics Profile
The symptom was stuck at "loading system resources" which usually happens to me when they update to a new client. Which they recently did to 2.2.9.

I believe it is a case something similar to "278-279-573-66145484" which has happened before. (see also - https://github.com/flathub/com.jagex.RuneScape/issues/23)

I have uninstalled flatpak runescape with:

flatpak uninstall flathub com.jagex.RuneScape

and when one tried to reinstall it with:

flatpak install flathub com.jagex.RuneScape

it returns error:

“error: Failed to install com.jagex.RuneScape/x86_64/stable: Wrong size for extra data https:// content.runescape.com/downloads/ubuntu/pool/non-free/r/runescape-launcher/runescape-launcher_2 .2.9_amd64.deb”

Last time, if I remember correctly, runescape changed something - like the location of the binary or perhaps provided it and flatpak started to work again.

Can someone please let Jagex know.

For the first time in years, I was able to load the client from the r/s script at the site, but even in "MIN" graphics mode, I can barely move.

I have a dual Intel Xeon E5-2650 v3 (20 core/40 thread)
64GB RAM
nvidia 1050ti

and was working flawlessly under ULTRA until 2.2.9

26-Jul-2021 10:02:14 - Last edited on 26-Jul-2021 15:08:04 by Weedmic

vegancookies
Feb Member 2021

vegancookies

Posts: 625Steel Posts by user Forum Profile RuneMetrics Profile
I couldn't download it either, but then I installed protontricks on flatpak, and that worked.

Protontricks is related to steam, which I do have installed using flatpak, but I don't understand why runescape installed via flatpak needs it, it's just, it works:

```
flatpak install protontricks
```


What this won't do is allow runescape to work well on xwayland (only applicable to nvidia users I believe).

From what the resident linux guru (hmmm) said on my thread, mesa will need to update, so hopefully for the next update I can move away from x11 (assuming it is patched in the next one).

Anyway, let me know if this also allows you to download/install runescape using flatpak.

The aur version for anyone with access seems to be working for me, and the steam as well (just, none of them on xwayland).
DG Service-fast, friendly, low cost, high value :)

27-Jul-2021 03:31:58

Tenblade
Jan Member 2021

Tenblade

Posts: 4,068Adamant Posts by user Forum Profile RuneMetrics Profile
I logged in after a month of not playing and now I have no sound at all. I uninstalled and deleted the cache files. Reinstalled and downloaded everything again and still no sound. What happened? Linux 18.04

05-Aug-2021 20:53:16

Themken

Themken

Posts: 152Iron Posts by user Forum Profile RuneMetrics Profile
So the bad memory leak from the summer has thankfully been fixed in the Mesa driver, good.

Not so good is that now the game seg(mentation )faults constantly :-( Meaning the whole game crashes (CtD) and very often too. I cannot do any dungeoneering like this.

I wonder whose fault it could be. Do not want to bark up the wrong tree.

The game runs incredibly well otherwise on my Manjaro PC even if there are some annoying bugs like the loot popup not closing itself automatically.

09-Sep-2021 14:48:45 - Last edited on 09-Sep-2021 15:46:19 by Themken

Santhiner
Aug Member 2014

Santhiner

Posts: 2Bronze Posts by user Forum Profile RuneMetrics Profile
I am having the same problems as the post above (Themken). Every time I teleport or if I cross over too many different areas while running, the game will crash. I have not tried dungeoneering, but things like boss encounters when creating an instance and entering instances the game will crash. Thankfully I've been doing Arch-Glacor so free deaths. I have been lucky to be able to just stay in the boss instance if it doesn't crash and there seems to be no other problems. I am also running on Manjaro, the Cinnamon distro.

02-Oct-2021 12:42:51

wwwShadow7
Feb Member 2013

wwwShadow7

Posts: 148Iron Posts by user Forum Profile RuneMetrics Profile
Not sure why, but recently runescape via snap in linux (arch + LTS kernel) is crashing hardcore in < 10 minutes of gameplay. On a ryzen 5700U with 64GB of RAM. AKA a system76 pangolin. I've been using the LTS kernel because it would crash like this on the mainline kernel. Now it seems to be any kernel. When it crashes it takes down my GUI if not terminated quickly. Locking up the keyboard and all the good old Xorg crash days of lore. If I don't run runescape my system is stable. I have kind of a slow connection with high latency, but it's reliable. It crashes with both PIA / VPN and no vpn. Please fix this as I cannot complete a farm run in less than 3x logins and 2x reboots, doing just herbs (x5). It's kind of acting like I'm running out of RAM. But how could I be with 64GB of RAM? That's some serious leakage if that's actually what's happening.

15-Oct-2021 21:42:11

wwwShadow7
Feb Member 2013

wwwShadow7

Posts: 148Iron Posts by user Forum Profile RuneMetrics Profile
I filed a bug report. It seems to be arch's latest LTS kernel. Currently the mainline kernel works fine 5.14. Previously the flip flop of that.

https://bugs.archlinux.org/task/72438

snap remove / snap install did NOT fix it for LTS kernel 5.10.73-1. Previously working fine on 5.10.72-1, but not mainline kernels.

16-Oct-2021 13:27:15

GoodChoice0
Feb Member 2021

GoodChoice0

Posts: 1Bronze Posts by user Forum Profile RuneMetrics Profile
I'm having this same issue. I tried all proton versions and none work anymore. I am trying to launch through steam. I am running the latest ubuntu 21.04 and it was working just a few days ago. As of this halloween update I cannot play the game for more than 10 minutes without it crashing. Works fine on windows on the same system.

20-Oct-2021 19:11:28

Quick find code: 409-410-916-65990459Back to Top