Forums

Can't disable authenticator.

Quick find code: 408-409-862-66127470

of 2
Bossy Brat
Nov Member 2014

Bossy Brat

Posts: 255Silver Posts by user Forum Profile RuneMetrics Profile
So I'll be receiving a new phone in around an hour and I've been trying to disable my authenticator since last night so I can apply it to my new device. I've tried logging in via phone, tablet, PC multiple times, I've received the email to do so every time but then when I click the disable button it makes me log in again, then says there was a problem handling my request.

I've tried flushing my DNS, I've cleared my cache, I've changed my registered e-mail, I've tried clicking "lost authenticator" and everything.

Nothing works. Kinda sick of it at this point.
Final Boss
Completionist
Veteran

30-Oct-2019 13:04:24

Skod River
Nov Member 2009

Skod River

Posts: 7,690Rune Posts by user Forum Profile RuneMetrics Profile
Hey you 2.

Have you tried this out , which i saw in another thread QFC 408-409-740-66127357

It seems to that workaround worked for them , so maybe could you be lucky it will work for you. ;)

Do believe Jagex are aware of it and are working on a fix. :)
Clan : Order Of Adventurers

FriendsChat : Ooa team

30-Oct-2019 13:54:21

D Ment3d
Jan Member 2020

D Ment3d

Posts: 3Bronze Posts by user Forum Profile RuneMetrics Profile
Hi, I have had this same issue since yesterday evening, I have now just managed to disable my authenticator and move it to my new mobile phone. I do not know if that's because the error was fixed or if I went around it through the process listed below.

Basically what I did was:

1) Opened runescape.com on incognito window (chrome);
2) Logged in and went in my account settings;
3) Clicked on authenticator settings;
4) I was prompted to log in again (and was asked for the authentication code given I was in incognito mode)
5) Then I clicked on 'Lost Authenticator?' option at the bottom;
6) An email was sent to my recovery email address, which I opened in another incognito tab;
7) In the email, instead of pressing the button that has taken me to the error page countless times, I copied the link and pasted it in another browser (firefox);
8) This way the error did not show and I had successfully disabled the authenticator.

Again, I do not know if this method worked cause it works or because the problem has been fixed. Nonetheless, I have decided to put it up here seeing there have been others with the same issue.

30-Oct-2019 14:58:18

Jeff3000333

Jeff3000333

Posts: 5Bronze Posts by user Forum Profile RuneMetrics Profile
I am having a similar problem and I still can't get it fixed even after following the steps above or advice from other forum posts. Here's the background of my issue:

I tried to log in one day to a new account (not the one I'm posting from now) and I couldn't log in because OSRS kept asking for my authenticator 6-digit code. I never set up an authenticator on this account so I'm at a loss there, thinking my account might have been hacked.

I went through and did the reset password link, and while I was doing that it asked something like "is this your email S******@gmail.com?". I was confused because that's not my email, so I said "no" and then it asked if another email was mine and it was correct so I said "yes".

I then got an email to reset my password, which I did successfully. However, after logging in to the account with the new email, it immediately started asking for the damn authenticator again! Since I never set up an authenticator in the first place, I still don't have this code.

So I clicked the "disable authenticator" link and eventually, I received an email link to try and disable the authenticator. After clicking on the link from my email it ALWAYS says "ERROR Sorry, the link you followed has expired or is not valid. Please try again."

So, naturally, I try again and I get more emails saying the same thing, sending me the same link to disable the authenticator. This never works and I always get the same error message.

I've tried to change my authorized email, but I can't do this without logging in, which I obviously can't do because I don't have the authenticator disabled.

I also tried using different browsers, going on incognito on all of them and such, but this didn't work either. Lastly I attempted to clear my cache, clear my DNS cache, and use different computers, all of which did not work.

Can anyone please help me with this? I'm quite frustrated that there seems to be no way to get out of this infinite loop.

Thanks!

13-Dec-2019 17:43:56

Malua
May Member 2006

Malua

Posts: 33,772Sapphire Posts by user Forum Profile RuneMetrics Profile
Hi there
Jeff3000333


The cache clearing and DNS cache flush should fix the problem you are experiencing.
You could also try this: Set up exceptions to your firewall for RuneScape

Make certain you are using the correct login because, when you said this "However, after logging in to the account with the new email," it sounds like you changed the login to a different one.
Forum Community Helper -
Information about the Community Helper Team

13-Dec-2019 20:39:05

Jeff3000333

Jeff3000333

Posts: 5Bronze Posts by user Forum Profile RuneMetrics Profile
Hey Maula,

Thanks for getting back to me! By my comment about “However, after logging in to the account with the new email,” I meant “Password” not email, I apologize that’s my mistake. So I am certain that I’m using the correct email.

I’ve already tried the cache clearing and DNS cache flush on a few browsers. As far as adding exceptions to the firewall, by this do you mean the firewall settings on my email account? If so then I don’t have access to this account, and my firewalls are disabled on my network to try and fix this.

Any other suggestions? Can somebody from Jagex manually disable my Authenticator?

Thanks!

13-Dec-2019 22:01:14 - Last edited on 13-Dec-2019 22:01:41 by Jeff3000333

Quick find code: 408-409-862-66127470Back to Top